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1 Setup 

1.1 Installation 

As at August 2023 QGIS 3.32 (or QGIS LTR 3.28) is the recommended version to use. Some 

screenshots in this document are from an older versions so may look slightly different to the 3.32 

interface (but the tools described work the same way).   

QGIS can be downloaded from here: https://qgis.org/en/site/forusers/download.html.  

1.2 Toolbars and panels 

When you first open QGIS it should look something like this. 

 

It’s important to remove any mapped drives from the Browser panel if they’re not being used (eg. drives 

only accessed occasionally via VPN) – they drastically slow down QGIS. For example, the S: and T: from 

above. 

 

 

 

 

 

 

 

https://qgis.org/en/site/forusers/download.html
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Right click on the top grey toolbar panel and from the Toolbars list tick on the Shape Digitising Toolbar. 

The Snapping and Advanced Digitising toolbars are also useful. 

 

Add data to the project by dragging and dropping to the Layers panel from the Browser or directly from 

the operating system file explorer. The layers are listed and can be grouped, and they show in the Map 

View Panel. 
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1.3 Data types 

1.3.1 Shapefiles 

Shapefiles are spatial vector filetype made of 4 – 6 components (.shp, .dbf, .prj, .shx and more). These 

component files must all be kept together and have the same name, otherwise the data will become 

corrupted. If a QGIS project file (.qgz) is moved (rather than using ‘Save As’) or if shapefile is moved, 

then the link between the QGIS project file and shapefile will be broken. In this case a new path can be 

specified. 

To load a shapefile to a QGIS project drag and drop the .shp file to the Layers window within QGIS. 

 

1.3.2 Geopackage files 

A geopackage is a spatial vector data type stored in one file with extension .gpkg. A gpkg can contain 

multiple layers but data downloaded from data providers usually only contains one layer.  

A gpkg file can be loaded to a QGIS project by dragging and dropping the gpkg file to the Layers 

window. 

 

1.3.3 Georeferenced images 

You can add Nearmaps jpg images (or other georeferenced images) to QGIS by dragging and dropping 

the file into the Layers window. Take care to keep .jgw and .tfw (world) files alongside .jpg  and .tif files 

to store the associated coordinate system information. 

 

1.3.4 XYZ tile base layers 

To add streamed base layers go to ‘XYZ Tiles’ or ‘WMS/WMTS’ in the Browser window. Right click to 

add a new connection. Paste in one of the service URLs from below, give the connection a name and 

Okay. Drag and drop the resulting layer into the Layers window.  

Google hybrid 

http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z} 

Google Satellite 

http://mt0.google.com/vt/lyrs=s&hl=en&x={x}&y={y}&z={z} 

Google maps 

http://mt0.google.com/vt/lyrs=m&hl=en&x={x}&y={y}&z={z}  

OpenStreetMap 
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https://tile.openstreetmap.org/{z}/{x}/{y}.png 

Bing Satellite Imagery 

https://t0.tiles.virtualearth.net/tiles/a{q}.jpeg?g=685&mkt=en-us&n=z 

 

 

1.3.5 WMS base layers 

Served Web Map Service (WMS) layers can be added to QGIS using the same method as XYZ layers.  

Nearmap 

To get the WMS URL, sign in to Nearmap (using your UWA email address) and go to Integrations>API 

Services. Select the API Key as the ‘University of Western Australia’ and the integration type as ‘Simple 

WMS’. Copy the link and then add as a new WMS service in QGIS. 

 

SLIP WMS layers 
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All public layers with WMS services are listed here: 

https://catalogue.data.wa.gov.au/group/?q=SLIP+Public 

All subscription layers with WMS services are listed here: 

https://catalogue.data.wa.gov.au/group/?q=SLIP+Subscription 

Eg: Environmental layers 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Environment/MapServer/WMSSe

rver 

Boundary layers 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Boundaries/MapServer/WMSServ

er 

Roads 

https://services.slip.wa.gov.au/arcgis/services/Landgate_Subscription_Services/Roads/MapServer/W

MSServer 

Aerial photographs 

https://catalogue.data.wa.gov.au/dataset/perth-metro 

https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic 

https://catalogue.data.wa.gov.au/dataset/perth-metro-archive 

https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic-archive 

 

1.4 Coordinate Reference Systems (CRS) 

Geographic Information Systems (GIS) differ from CAD applications because they can accurately 

overlay datasets with different coordinate systems. This means it is easy to combine datasets from 

multiple sources. It is important, however, to specify the coordinate system for the QGIS project and 

when exporting to dxf or other formats.  

Datasets exported to dxf will need to be given the same coordinate system as the base feature survey 

(or other base data sources) to be used in AutoCAD. If the coordinate systems don’t match then layers 

will not overlay (even if manually moved). 

The common coordinate systems used in Perth and their codes are:  

• Perth Coastal Grid (GDA2020 PCG2020): EPSG 8031 

• (Perth Coastal Grid (GDA94 PCG94): EPSG 102216) 

• GDA2020 MGA50: EPSG 7850 

• (GDA94 MGA50: EPSG 28350) 

Other coordinate systems used in Western Australia are: 

• GDA2020 MGA51: EPSG 7851 

• (GDA94 MGA51: EPSG 28351) 

 

• GDA2020 MGA52: EPSG 7852 

• (GDA94 MGA52: EPSG 28352) 

https://catalogue.data.wa.gov.au/group/?q=SLIP+Public
https://catalogue.data.wa.gov.au/group/?q=SLIP+Subscription
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Environment/MapServer/WMSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Environment/MapServer/WMSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Boundaries/MapServer/WMSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Boundaries/MapServer/WMSServer
https://services.slip.wa.gov.au/arcgis/services/Landgate_Subscription_Services/Roads/MapServer/WMSServer
https://services.slip.wa.gov.au/arcgis/services/Landgate_Subscription_Services/Roads/MapServer/WMSServer
https://catalogue.data.wa.gov.au/dataset/perth-metro
https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic
https://catalogue.data.wa.gov.au/dataset/perth-metro-archive
https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic-archive
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GDA2020 (Geocentric Datum of Australia 2020) is replacing GDA94, so over the next years GDA2020 

will become more common than GDA94. 

Please note there are many more coordinate systems than the ones listed above. The list of Western 

Australian towns with their own local coordinate systems is here: 

https://www0.landgate.wa.gov.au/business-and-government/specialist-services/geodetic/project-grids 

Most of these local town grids do not have their coordinate systems defined in QGIS so cannot be 

selected from the list offered. They can be manually added using custom CRS definitions. 

 

1.4.1 CRS transformations 

QGIS can combine layers that have different coordinate systems by transforming coordinate systems 

on the fly. Sometime QGIS will ask which transformation option you want to use. You can just accept 

the defaults from these message.  

But if you want to use the most accurate transformation options, get into the habit of using the 

following. 

• When transforming between GDA2020 and GDA94 always choose the third option, which uses 

the 8447 transformation identifier.  

 

 

 

 

https://www0.landgate.wa.gov.au/business-and-government/specialist-services/geodetic/project-grids
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• When transforming between WGS84 and GDA94 use the 1150 transformation. 

 
• When transforming between WGS84 and GDA2020 use the option that combines the 1150 and 

8447 transformations (to form 9691). 

 

 



8 
 

1.5 Colours 

A colour palette can be set up and saved as a .gpl file. This file can then be imported to any computer 

running QGIS. The file only needs to be loaded once on a computer and will then be available to all QGIS 

projects. 

To set up a colour palette go to Settings>Options>Colours. Use the ‘-‘ button to remove the default 

colours. Use the ‘+’ button to specify new colours. You can add colours using RGB values or HTML 

codes (eg #ff0001) (but not CYMK values). You can give the colours names by double clicking in the 

‘Label’ column. After you have added all the colours in your palette click the “disk” button (Export 

Colours) in the RHS menu. Save this .gpl file somewhere.  

 

To load the gpl file onto another computer, open QGIS and go to Settings>Options>Colours>RHS menu 

“folder” icon (Import colours from file). These colours will be available as Standard Colours through all 

Symbology menus. 

QGIS currently does not allow for the definition of colours using the CYMK system. It also does not 

allow for defining a colour space (RGB or CYMK) when exporting images. 
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2 Data conversions 

2.1 Processing data for export to AutoCAD dxf 

QGIS can export vector data (from shapefiles or geopackages) to dxf format. This is a good way to get 

various vector dataset into AutoCAD.  

Some pre-processing must be done before exporting: 

• All datasets must be reprojected to the same coordinate system as the target AutoCAD 

drawing (the feature survey, Nearmap image or any other dataset you wish to combine your 

exported data with in AutoCAD). 

• If the dataset has elevation values (eg. contour lines), then the data needs to be converted to a 

3D shapefile before being exported to dxf.  
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• Polygon datasets will export to dxf as hatch areas, so it can be useful to convert them to lines 

so they export to polylines instead.  

• If datasets are large it can be useful to clip them to your area of interest before doing the above 

processing, but it is not absolutely necessary. 

2.1.1 Clip layers 

To clip shapefiles/geopackages: 

1. Create a shapefile to mark the boundary of your area of interest. Go to Layer>Create 

Layer>New Shapefile Layer. Specify the location of the file and the name. Specify the file to be a 

polygon and give it the same coordinate system as your AutoCAD (and QGIS) project. 

 

2. Highlight the new clip layer in the Layers panel then click on the ‘Toggle Editing’ pencil button in 

the top toolbar. Click on the ‘Add Polygon Feature’ star button. Click on the Rectangle from 

extent digitising tool. Now click to form a rectangle. Right click to finish the shape. 
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3. Click the ‘Toggle Editing’ pencil again and select Save edits. 

4. In the Processing Toolbox window type “Clip” into the search window. Open the tool called 

‘Clip’. Choose an original dataset as the first layer and the newly created area of interest (clip 

boundary) shapefile as the second. Specify the location and name of the output shapefile. 

 

 

2.1.2 Add Z values to contour data 

1. In the Processing Toolbox window type “Z”. Open the tool called ‘Set Z value’. 

2. Specify the contour shapefile. Under Z Value click on the ‘Data defined override box’ and 

choose the attribute (field) containing the contour elevation value. Specify the location and 

name of the output file. 
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2.1.3 Reproject layers to the coordinate system being used in AutoCAD  

1. In the Processing Toolbox window type in “reproject”. Open the ‘Reproject layer’ tool.  

2. Specify the dataset to reproject and choose the output coordinate reference system. Choose 

the same as the desired coordinate system for the AutoCAD file (eg. GDA94 MGA50 or 

GDA2020 MGA50). 

 

Remember all layers that are to be exported to dxf need to be in the same coordinate system 

before exporting. 

 

When reprojecting between GDA2020 and GDA94 the following window will open, asking which 

transformation to use. Always choose the third option, which gives the 8447 transformation 

identifier. When reprojecting between WGS84 and GDA94 use the 1150 transformation. 
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2.1.4 Convert polygons to lines 

1. Polygon data in QGIS exports to hatch data in AutoCAD. Sometimes close poyline geometry is 

a preferred option. To get this output first convert the polygon data to line data. In the 

Processing Toolbox window type in “polygon”. Open the ‘Polygon to line’ tool.  

2. Specify the layer to convert and the output location and file name. 

2.1.5 Set symbology and labelling 

1. You can export some layer styling to dxf – the symbology and labels. See Sections 4.2 and 4.3 

for instructions to style vector layers. 

2.2 Export to dxf Method 1 - for multiple layers without z values 

1. Make sure all layers to are prepared (converted to lines, reprojected to the coordinate system of 

the destination AutoCAD file (eg GDA94 MGA50)). 

2. Zoom to your area of interest (to define the extent of exported data if you have not clipped it 

already). If all layers are clipped, ignore this step. 

3. Go to Project>Import/Export>Export Project to DXF. 

4. Make sure the correct layers are selected. Specify the correct coordinate system. Specify the 

output file location and name. Select ‘Feature Symbology’ if exporting polygon layers with 

symbology set. Set the symbology scale to 10000 (or appropriate). Selected ‘No Symbology’ if 

exporting line data only.  
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5. Tick ‘Use layer title as name if set’, ‘ Export features intersecting the current map extent’ and 

‘Export labels as MTEXT elements’ (if the data is labelled). Leave all other defaults. 

Tip: If, when opened in AutoCAD, the exported dxf has an error when using COPYBASE then save the file 

as a 2013 dwg and reopen. There are not usually errors with Method 1. 

Note that contour data (with z values defined) exported using Method 1 will convert to 3D polyline 

layers which can be annoying in AutoCAD. Method 2 is the best method for exporting contour data to 

2D polylines with elevation values. 

 

2.3 Convert to dxf Method 2 - for layers with z values 

1. Select the line layer with z values specified (see Section 2.1.2, above). Right click and choose 

Save Features As. 

2. Specify the location and name of the output file, and specify the format as dxf. Specify the 

output coordinate system (to match other data already in AutoCAD). Choose ‘Linestring’ as 

geometry type. Tick ‘Include z-dimension’. 

3. Open the resultant dxf in AutoCAD.  

This method of export doesn’t allow for exporting labels. In AutoCAD the z values will show in the layer 

Properties as elevation values. 
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3 QGIS print layouts 

3.1 From QGIS layers to Illustrator layers 

Data in shapefile/geopackage format is vector data. If exported as a vector pdf from QGIS, the data can 

be opened and edited in Illustrator. By exporting multiple layers using the same print layout, each pdf (of 

a single vector dataset) will overlay correctly in Illustrator. These are the steps for exporting data to 1:10 

000 at A3, for example. Some extra information about using Print Composer is here: 

https://docs.qgis.org/3.28/en/docs/user_manual/print_composer/overview_composer.html 

1. Make sure the QGIS project coordinate reference system to the one you want to use for the 

Illustrator file, via Project>Project Properties>CRS. 

 

2. Start a new print layout (Project>New Print Layout).  

 
 

https://docs.qgis.org/3.28/en/docs/user_manual/print_composer/overview_composer.html
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3. Right click on the blank page view>Page Properties. This opens in the Item Properties panel. 

Here set the page dimensions and set the page background to be transparent using the 

transparency slider.  

 

 

4. Add a map to the page (Add item>Add map). Make it the full page size by snapping to a page 

corner then using the dialogue box to enter the map item dimensions. 

 



18 
 

5. Zoom (mouse wheel) and pan (Move item content tool) to the project area.  Specify the scale 

as 10000 (with the map item selected>Item Properties).  

 
 

The page should look like this. 

 

6. In the main QGIS map view turn on only one layer and set the symbology (and labels). 

7. Back in the print layout view go to the Layout tab (next to the Item Properties tab) and tick on 

the ‘Always export as vectors’ option. If exporting an image (raster) dataset then tick the ‘Print 

as raster’ option and set the Export resolution to 300 dpi. 
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8. Go to Layout>Export as PDF. Accept the defaults and export the print layout.  

 

 

9. Repeat 7 and 8 for all QGIS layers you need in Illustrator. Be careful not to pan or zoom the map 

area in print layout view between exporting layers. 
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10. Open the pdfs in Illustrator and use Paste in Place to overlay them as layers in a single 

Illustrator document. Provided they were all exported from the same QGIS print layout then 

they will overlay correctly in Illustrator. 

3.2 Making maps 

The print layout described in Section 3.1 didn’t have a legend, scale bar, north arrow or title. To create a 

proper map layout you would need to add these items to the print layout page. 

1. Insert these items using the Add Item menu. Drag a rectangle on the map page to specify the 

location of the item. 

 

2. To edit each map element click on it the edit via the Item Properties panel. Generally the default 

north arrows and scale bars will not need editing.  

3. The legend item should be edited to tick on ‘Only show items inside linked map’. To edit the 

legend text untick the ‘Auto update’ option then double click on legend entries to edit the text. 
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4. Use a Label item to add a map title. Edit the text and font via the Item Properties. 

 

5. You may want to resize the map to add a page margin. Use the map item Position and Size 

panel to set the map dimensions. 
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6. The map should look something like this. Export as vector or raster to image or pdf as per 

Section 3.1. 
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4 Working with vector data 

4.1 Attribute table 

A shapefile/geopackage comprises feature data and feature geometry. In the map view you see the 

geometry of the features - each feature has a representative point, line or polygon. In the attribute table 

you can view and interrogate the data values associated with those features. 

1. To open the attribute table, right click on the layer and click on ‘Open Attribute Table’. 

 

 

2. This is what an attribute table looks like. The attribute (column) names are limited to 10 

characters in a shapefile, so they are often a little cryptic (there are no restrictions in 

geopackages). Some datasets from data.wa.gov.au (and other agencies) come with data 

dictionary/metadata documents which explains what each attribute is. 
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3. You can sort the columns by clicking on the attribute name. You can highlight features (which 

will also highlight the corresponding point, line or polygon) by clicking on the row number. 

 

 

4. You can dock the attribute table window and choose to ‘Show Selected Features’ (bottom left 

button). Then if you use the Select Features tool (from the main toolbar) to click on a feature, 

its data will be displayed in the attribute table. The highlighted feature is shown in yellow. You 

have to click on the layer name in the Layers list before you can highlight features from that 

shapefile/geopackage. 



25 
 

 

 

5. An alternative way to see the attribute data for a feature is to use the Identify tool (from the 

main toolbar) to click on a feature. This tool will pop up a data snapshot in the Identify Results 

window and mark the identified feature in red. You have to click on a layer name in the Layers 

list before you can identify features from that shapefile/geopackage. 

 

 

6. To edit a shapefile/geopackage (data or geometry) you click on the Toggle Editing icon in the 

menu bar. You can then add attributes, edit values, and add or modify feature geometry. You 

need to click the Toggle Editing button again to save edits and end the editing session once 

you’re finished. 
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4.2 Symbology 

Symbology refers to the colours and style of the displayed data layers (shapefiles or raster images). 

There are some notes about Symbology here: 

https://docs.qgis.org/3.28/en/docs/user_manual/working_with_vector/vector_properties.html 

Here are some steps to setting basic style options. 

1. To access the Symbology menu, right click on a data layer and go to Properties>Symbology. 

From here you can choose to symbolise all features the same (Single Symbol) or use different 

symbols/colours depending on the value of the feature for a specified attribute (Categorized).  

https://docs.qgis.org/3.28/en/docs/user_manual/working_with_vector/vector_properties.html
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2. If you choose the Categorized option then choose the attribute containing the values you want 

to delineate. For example, Column = wgs_wetl_2. This will show different types of wetlands as 

different colours. 
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3. After choosing the attribute/column press the ‘Classify’ button. You will see all the values for 

the attribute listed. The bottom blank value captures any data that has a NULL value. 

 

 

4. To make changes to all the symbols (eg remove border lines) you click on the button that says 

‘Change…’. Click on where it says ‘Simple Fill’ then next to ‘Stroke Colour’ select ‘Transparent 

Stroke’ to remove the stroke. Click okay to get back to the previous menu. 
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5. To set the colour for each value, double click on the ‘Symbol’ swatches. Click on the down 

arrow next to the colour sample where it says ‘Colour’. Choose your colour from the list of 

‘Recent colours’, ‘Standard colours’ or click ‘Choose colour’ to select a new colour.  
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6. You can also choose to make the fill colour transparent and set a boundary colour/stroke style. 

For example: a red dashed outline means ‘Fill colour’ = transparent, ‘Stroke colour’ = red, ‘Stroke 

style’ = dashed line and you can change stroke width. 
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7. Once you have set all the colours and styles you click Okay to get back to the map view. You 

can still edit the styles from here by double clicking on the colour swatches in the Layers list. 
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4.3 Labels 

You can add labels to your map view (and therefore print layout) using values from the attribute table. 

You can manually move labels if the automatic label positions are not good.  

Some notes are here: 

https://docs.qgis.org/3.28/en/docs/user_manual/working_with_vector/vector_properties.html 

These are steps to getting quick basic labels. 

1. Right click on a layer and go to Properties>Labels. The most common is to choose ‘Single 

Labels’ from the labelling options. 

 

https://docs.qgis.org/3.28/en/docs/user_manual/working_with_vector/vector_properties.html


33 
 

 

2. From the ‘Label with’ drop down menu, choose the attribute with the labels you want to display. 

 

 

3. Then set the font type, colour and size in the ‘Text’ section. 

 

 

4. You may like to put a buffer around the font to make a visible on top of the map. You can adjust 

the width and colour of the buffer. 
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5. In the ‘Placement’ tab you can choose Offset, Around centroid or Horizontal (slow) as the best 

label placement options. Slide the ‘Priority’ bar to High to make sure your labels are not hidden 

by other data layers. 

 

 

 

6. Click Okay to display the labels, as below. 
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7. You can manually move labels that have not been placed in a good location. First open the 

‘Label Toolbar’ by right clicking in the main toolbar area. Then tick on the Move Labels tool 

within the Label Toolbar. Click on the label you want to move. You will be asked which field to 

store the label position data against. You must choose an attribute that contains a unique 

identifier for the features so that you can move each label independently. Drag and drop labels. 

Take note of the scale you’re working at because the manually moved labels will need to be 

specifically placed to work at a given print layout scale. 
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8. If you are labelling data where many features have the same attribute value then you may end 

up with labels like below. The work around for this situation is to dissolve the shapefile and use 

this dissolved version to produce the labels (and reduce duplicates). 
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5 Data Analysis 

5.1 Elevation Profile 

This tool is good for extracting section profiles using contour or Digital Elevation Model data as an 

input. Only use this tool in QGIS versions 3.32 or above. 

1. Make sure you have elevation contour or a Digital Elevation Model raster dataset loaded to your 

project. 

2. Create a new shapefile layer for line geometry (see Section 2.1.1) in the same coordinate 

system as your QGIS project (and connected AutoCAD project). 

 
 

3. Start editing on this layer and use the Add Line Feature tool to draw your intended section line. 

Right click to end the drawing then toggle editing off and save your edits. 

 
 

4. If using an elevation contour dataset, we need to specify where the elevation data is stored. 

Right click on the contour layer > Properties > Elevation. Set the Elevation Clamping to Absolute, 

and specify Offset value as the Elevation field. Set the Interpretation option to Continuous 

Surface. Accept the other defaults. 
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5. Now open the Elevation Profile tool via the main menu View > Elevation Profile. 

6. You will see your project layers show in the tool layers panel. Click on the layer where you drew 

your section cut line. Then use the Capture Curve From Feature to click on your section line. 

 

7. Tick on the contour layer (from Step 4). You should see the section cut elevation profile in the 

tool display. If you hover the curser along the profile you’ll see the corresponding location in the 

map view panel. 
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8. You can export this section profile to dxf. Use the Export tool (available in QGIS 3.32 but not 

3.28). Select Export 2D profile. Specify dxf as the output data type. 

 
9. This will open in AutoCAD with units in metres. 

 

10. It is a good idea to export the section cut line (as opposed to the profile) to dxf as well. Then 

you have the exact corresponding section line to use on plan drawings. Use the instructions 

from Section 2.2. 
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5.2 Join csv table data to shapefile/geopackage data 

5.2.1 Add csv data to QGIS project 

Any tab/space/comma/character separated data can be imported to QGIS. If there are easting/northing 

or latitude/longitude fields in the data then point geometry will be created, if not you can import the data 

as a table. 

1. Go Layer>Add Layer>Add Delimited Text Layer. 

2. Navigate to the file and set the appropriate data type (eg comma separated for CSV data).  

3. Specify the easting and northing fields (or columns). Specify the data CRS.  

4. You can adjust the data type of each column (eg text, integer or decimal number). 

5. Then click Add. 

6. If a point layer is added (as in this example) it is just a temporary layer specific to that QGIS 

project document. You will need to save to a shapefile (or another format) to keep as a spatial 

dataset that can be used elsewhere. 
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5.2.2 Join csv data to shapefile/geopackage 

You may want to join tabular data to a spatial dataset and then visualise the spatial distribution of 

values from the table. This is a good workflow for connecting ABS tabular data to their spatial datasets 

to visualise demographic distributions. 

1. You need one spatial dataset and one csv file each with a field (column) containing the same 

set of unique IDs. 

2. Prepare the clean .csv file in Excel (or equivalent), with no merged columns or rows and short 

column headers. No need to include easting/northing or latitude/longitude fields. Import the 

table to QGIS using instructions above, but tick ‘No geometry’ in the Geometry Definition 

section.  

 

This example file contains ABS data about distance from work per Destination Zones (DZN). 

Each DZN has a unique ID. 

 

The corresponding spatial dataset has the spatial extent DZNs for my area of interest. 
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3. Use the ‘Join attributes by field value’ tool to join the tabular data to the spatial data using the 

DZN unique IDs. 

 
 

4. Specify the Input layer (the spatial dataset), the Input layer 2 (tabular data) and the same 

unique identifier fields from each. These identifier fields will need to be of the same type (eg 

string/integer).  

 

Select a one-to-one join. Save to a shapefile or geopackage output file (or a temporary layer for 

testing).  
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5. Now symbolise the output layer using the tabular data fields. 

For example we can categorise by the distance to work for people working in each of these destination 

zones. 

 

And the map view will look like this, which is a useful visual representation or the tabular data. 
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5.3 OpenStreetMap data download using QuickOSM plugin 

This plugin allows you to download data from within QGIS. 

1. Install the plugin via Plugins > Manage and Install Plugins. Search for QuickOSM and click 

Install. 

 

2. Open the tool via the toolbar icon. 

 

 
 

3. Zoom to your area of interest. Then in the tool specify the query Key and Value, and set the 

search area to Canvas Extent. Then click Run Query.  
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Some suggested searches for use in QuickOSM: 

Key Value 

highway path 

highway track 

highway footway 

highway cycleway 

leisure playground 

amenity drinking_water 

amenity bench 

amenity bbq 

amenity toilets 

 

4. The output layers will be loaded to QGIS in point, line and polygon layers. For example here are 

the outputs from searches for toilets, tracks and paths. This data is loaded as temporary layers 

and should be saved to shapefile or geopackage if you want to keep the data. 
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