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1 Installing QGIS 

As at August 2023 version 3.28 is recommended. You can download the installer from here: 

https://www.qgis.org/en/site/forusers/download.html and it’s called QGIS Standalone Installer Version 

3.28. 

2 Coordinate reference systems (CRS) and vertical datums 

2.1 Coordinate reference system (CRS)  

• Also just called a coordinate system.  

• Made up of a geographic coordinate system + projection. eg. GDA94 (geographic ) MGA50 

(projection). 

• The geographic coordinate system component is based on a datum (which defines the earth’s 

shape). The projection component converts the 3D surface to 2D. 

• A projected CRS defines X/Y (easting/northing) coordinates. A geographic CRS defines 

latitude/longitude coordinates. 

• Each CRS has a unique EPSG code. 

• You can transform between CRSes in QGIS and using online converters. 

 

Local CRSes for Perth  

• GDA94 PCG94 (EPSG 102216) (Swan Coastal Plain only)  

• GDA2020 PCG2020 (EPSG 8031) (Swan Coastal Plain only) 

Common CRSes for Australia 

• GDA94 MGA50 (EPSG 28350), GDA94 MGA51 (EPSG 28351) etc 

• GDA2020 MGA50 (EPSG 7850), GDA2020 MGA51 (EPSG EPSG 7851) etc 

 

https://www.qgis.org/en/site/forusers/download.html
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MGA Zones 

 

Other custom coordinate systems can be specified via Settings> Custom CRS using the Proj 4 

specification: 

 Eg. Geraldton Coastal Grid 94 

+proj=tmerc +lat_0=-29.1 +lon_0=114.5833333333333 +k=1.00000628 

+x_0=50000 +y_0=3350000 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 

+units=m +no_defs  

 

Local CRS for the Bay of Plenty Region, New Zealand 

• NZGD2000 BOP2000 (EPSG 2106)  

Common CRS for New Zealand 

• NZGD2000 NZTM2000 (EPSG 2193) 

 

2.2 Vertical datums 

• A reference system that defines the 0 point for z coordinates. 

• There are datum acronyms but not EPSG codes. 

• You can transform between them using online converters but not in QGIS. 

 

Common for all Australia 
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• Australian Height Datum (AHD) 

Common for all New Zealand 

• New Zealand Vertical Datum 2016 (NZVD2016) 

Local vertical datum (LVD) for the Moturiki Region, New Zealand  

• Moturiki 1953 

 

Relationships between New Zealand vertical datums. Source: LINZ. 

 

2.3 GDA2020 

GDA2020 is currently the best geographic coordinate system to use in Australia. It replaces GDA94. 

GDA2020 accounts for a 1.8m shift in the earth’s surface (between 2020 and 1994). Landgate’s 

recommended transformation from GDA94 to GDA2020 is EPSG 8447, which is ‘2D conformal + 

distortion NTv2 grid file’ and described here: https://www0.landgate.wa.gov.au/business-and-

government/specialist-services/geodetic/gda2020 

Whenever a box pops up in QGIS asking you which type of transformation you want to use from GDA94 

to GDA2020 (or vice versa), always use the 8447 transformation. When asked which WGS84 to 

GDA2020 transformation always use the 1150 and 8447 version. 

https://www.linz.govt.nz/guidance/geodetic-system/coordinate-systems-used-new-zealand/vertical-datums/vertical-datum-relationship-grids
https://www0.landgate.wa.gov.au/business-and-government/specialist-services/geodetic/gda2020
https://www0.landgate.wa.gov.au/business-and-government/specialist-services/geodetic/gda2020
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2.4 Transforming New Zealand elevation values between vertical datums 

(online) 

There is an online tool for transforming between New Zealand vertical datums here: 

https://www.geodesy.linz.govt.nz/concord/index.cgi?Advanced=2 

General information about New Zealand vertical datums here: 

https://www.linz.govt.nz/guidance/geodetic-system/coordinate-systems-used-new-zealand/vertical-

datums/vertical-datum-relationship-grids 

Steps to transform elevation values: 

1. Create a comma separated file (.csv) of spot heights with the fields: easting, northing, elevation.  

a. You can do this in QGIS by creating a point shapefile with these three fields (and values 

populated) from spot height data, or from points data extracted from contour data (use 

the Extract Vertices tool).  

b. Populate the coordinate values using Attribute Calculator with $x for easting, $y for 

northing. X and Y values are in the layer CRS (not the project CRS).  

c. Then export this shapefile to CSV using Right click>Export>Save Features As. 

2. You need to know the vertical datum of the elevation values and the CRS of the easting and 

northing values. 

3. Open the online tool. Specify the vertical datum you’re transforming from and to and the 

coordinate system. Eg to transform elevation values from NZVD2016 to Moturiki 1953 with the 

BOP2000 CRS, set these parameters, then click Enter coordinates. 

 

 

4. Open your csv file using a text editor (eg Notepad). Copy the values from this file. Paste into the 

online converter. 

https://www.geodesy.linz.govt.nz/concord/index.cgi?Advanced=2
https://www.linz.govt.nz/guidance/geodetic-system/coordinate-systems-used-new-zealand/vertical-datums/vertical-datum-relationship-grids
https://www.linz.govt.nz/guidance/geodetic-system/coordinate-systems-used-new-zealand/vertical-datums/vertical-datum-relationship-grids
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5. When you click Convert coordinates the output appears as: easting, northing, original elevation, 

northing, easting, converted elevation.  

 

 

 

6. You can then copy this converted elevation data back to your csv file. Load the csv back into  

QGIS and export to shapefile again (then on to an elevation interpolation or contours). 
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2.5 Transforming coordinates between coordinate reference systems (CRS) 

online 

If you want to transform whole datasets (tif/shp/gpkg/dxf/dwg) from one coordinate system to 

another then it’s easiest to use the reprojection tools in QGIS.  

If you have one or two sets of New Zealand coordinates that you want to transform from one CRS to 

another then you can use an online converter here: https://www.geodesy.linz.govt.nz/concord/ 

A general coordinate converter for all CRS is here: 

https://epsg.io/transform#s_srs=4326&t_srs=7850&x=NaN&y=NaN 

1. Using the LINZ converter, if you want to transform coordinates from NZGD2000 NZTM2000 

(EPSG 2193) to NZGD2000 BOP2000 (2106) then use the following parameters.  

 

2. Click Enter coordinates. Then paste in the easting and northing coordinates you want to 

convert. Click convert coordinates. 

 

 

https://www.geodesy.linz.govt.nz/concord/
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2.6 Figuring out coordinate reference system (CRS) of CAD data 

CAD files (dwg and dxf) do not have the coordinate system or vertical datum information ‘written into‘ 

the file. The best way to find out which coordinate systems are being used is from the paper space title 

block notes or extra information given with the data. 

If you do not have the CRS written down then one way to figure it out is to compare to data with a 

known CRS.  

• Download a Nearmap image with a specified CRS (or export vector data to dxf from QGIS in a 

known CRS) then add this data to your dwg and compare with your mystery data. 

• In Perth you can tell the difference between GDA 94/2020 PCG94/2020 and GDA94/2020 

MGA50 because the PCG easting and northing values are much smaller than the MGA 

coordinates. This means they plot in very different locations in CAD model space. 

 

Eg. GDA94 PCG94 coordinates near Perth look roughly like this: 53541,254347 

GDA94 MGA50 coordinates near Perth look roughly like this: 386789,6456024 

 

So data in these two different CRSes looks roughly like this in CAD: 
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• It’s more difficult to tell the difference between GDA 94 PCG94 and GDA 2020 PCG 2020 or  

GDA94 MGA50 and GDA2020 MGA50. The update to Australia’s geographic coordinate system 

(Geodetic Datum of Australia – GDA) is small because it only accounts for movement of the 

earth crust. In Perth, identical sets of coordinates in GDA94 MGA50 and GDA2020 MGA50 are 

only 1.8m apart. So, this difference can be hard to detect.  

o It is best to compare vector data to determine if your datasets are in these two CRSes 

because you may not see the difference if checking against an aerial photograph. 

o Data in a GDA94 and GDA2020-based CRS will look like this in CAD. 

 

 

2.7 Reprojecting any dataset between coordinate reference systems (CRS) in 

QGIS 

In QGIS, any dataset stored in a common CRS can be transformed to another common CRS. Datasets 

in GIS vector formats (eg shapefiles, geopackages, geodatabases) will always have a CRS specified and 

written into the data (unless it is broken/missing component files).  

Image files in tiff or jpg formats can have CRS information stored in side car .tfw and .jgw world files 

(you’ll notice this with Nearmap downloads). Geotiff images have the CRS information embedded and 

no world file. World files are required when using the GEOREFIMG plugin to load georeferenced images 

to AutoCAD. 

CAD data (dxf or dwg) doesn’t have a specified CRS written into the data but it will (usually) have been 

drawn in a location corresponding to a common CRS (eg. not at 0,0). In QGIS you can assign a CRS to 

imported dxf /dwg data and then transform as needed. 
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Some useful workflows are below. 

2.7.1 Reproject vector data before exporting to dxf 

This is a useful workflow if you have vector data in QGIS that you want to export to dxf to use in CAD. 

All datasets exported from QGIS to dxf must have the same CRS as the CAD file you intend to add 

to/create. 

1. Check the dataset has a CRS assigned by hovering on the layer in QGIS and checking there’s an 

EPSG value. 

 

2. Open the Reproject layer tool. Specify the layer you want to reproject and the output CRS. You 

can save the output directly to dxf if you don’t want to retain any layer styling. Eg. Here 

transforming from GDA2020 MGA50 to GDA 2020 PCG2020. 

 

 

 

2.7.2 Import dwg/dxf data, reproject then export back to dxf  

If you have a drawing that you want to combine with another drawing but they’re in different coordinate 

reference systems then you will need to reproject one in QGIS before combining in CAD. Just manually 

moving a drawing isn’t accurate because it doesn’t account for the distortions that are particular to 

each CRS. 

This work flow is quite labour intensive, so you’d likely only do it for key layers from a drawing. 
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1. Determine the CRSes of the two CAD drawings you want to combine/XREF in. Choose the 

layers you want to reproject to match the other drawing. Save these to a new 2013 dxf file. 

2. Import the new dxf to QGIS using the Project>Import/Export>Import Layers from DWG/DXF. 

Specify the import CRS and an output geopackage (gpkg) location. Tick off ‘Expand block 

references’. This imports the dxf in the CAD layers, but only the centre points of the blocks – 

not all the block geometry. 

3. Identify which of the imported layers contain the original data from your dxf. Use the Reproject 

layer tool to reproject each of these layers individually. You can just output to temporary layers 

for this step.  

4. Rename the output layers to something meaningful. 

5. Use the Project>Import/Export>Export Project to DXF tool to export these reprojected layers 

back to dxf. Make sure only the right layers are ticked on in the export. Set the parameters as 

below. 

 

 

6. In AutoCAD you will see the drawing layers have moved to the reprojected location. The block 

centrepoints will come in as little circles (you can make them bigger by changing the point 
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styling in QGIS before export). These are the block anchor points and you will need to reinsert 

your blocks. 

2.7.3 Reproject image files for use in CAD 

1. Check the image has a CRS assigned by hovering on the layer in QGIS and checking there’s an 

EPSG value. 

2. Open the Warp (reproject) tool. Specify the image to reproject. Specify the output CRS. In the 

Advance Parameters section use the ‘plus’ button to add a “TFW = YES” entry. This specifies 

that a world file will be created. Leave all the other defaults and specify the output tif location. 

 

3. The output will look like this. This image can be loaded to AutoCAD using the GEOREFIMG 

plugin. 
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2.7.4 Create a world file for a georeferenced image (so it can be opened in CAD) 

If you have a georeferenced geotiff that doesn’t have a world file (tfw or jgw) then you can create one in 

QGIS. This enables you to load the image to AutoCAD using GEOREFIMG. 

1. Check the image has a CRS assigned by hovering on the layer in QGIS and checking there’s an 

EPSG value. 

2. Open the Extract Projection tool. Make sure the correct image is specified then click Run. 

3. A .wld file will be created next to the specified image. Just rename the file extension to . 

tfw/.jgw. Take care not to change the actual file name (it must be the same as the image file 

name). 

3 Data processing in QGIS 

3.1 Calculating x/y coordinates and area 

When calculating the x or y coordinates into the attribute table, the $x and $y commands default to 

returning the values in the layer’s coordinate system (NOT the project CRS). 

To return values in a specific coordinate system use these expressions in the Field Calculator (from 

https://gis.stackexchange.com/questions/387846/calculating-area-in-project-with-multiple-layers-with-

different-crs-in-qgis). 

If you want coordinates in EPSG 4326, use this expression 

x(transform($geometry, layer_property(@layer_name,'crs'), 'EPSG:4326')) 

or coordinates in the project CRS 

x(transform($geometry, layer_property(@layer_name,'crs'),@project_crs)) 

The x can be replaced with y (for latitude/northing) or area (for polygon area calculation). 

3.2 Creating raster surfaces from elevation contour lines 

The TIN interpolation algorithm is a good interpolation method for elevation data. QGIS does not 

produce a TIN mesh (as is done with AutoCAD), but a raster surface. These are the steps: 

1. Starting with spot heights data (points) or contours (lines), reproject to a projected coordinate 

system (eg GDA94 MGA50). 

2. Use that dataset as input to the ‘TIN Interpolation’ tool. Specify which attribute has the 

elevation data. Leave the Interpolation method as Linear. Use the input layer to define the 

extent. Specify the output cell size (say, 0.5 or 1m). 

https://gis.stackexchange.com/questions/387846/calculating-area-in-project-with-multiple-layers-with-different-crs-in-qgis
https://gis.stackexchange.com/questions/387846/calculating-area-in-project-with-multiple-layers-with-different-crs-in-qgis
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3. For visualising the output you can set the number of classes to display and their thresholds via 

the Properties>Symbology. 

4. Can use multiple elevation surfaces to calculate things like depth to groundwater (eg surface 

elevation (mAHD) – groundwater level (mAHD)). And can use elevation surface to calculate 

elevation contours using the Contour tool. 

 

3.3 Clip an image/raster/surface layer 

Raster surfaces created via interpolation always fill out the rectangular extent of the input data meaning 

that there will always be areas near the edge of the surface that are not meaningful. It’s useful to clip 

the raster to the area that bounds the input data exactly (not as a rectangular bounding box).  

1. Create a polygon layer defining the boundary of the meaningful area of the interpolated surface 

(usually the area tightly bounding the input data). Or just the defining the area of the raster you 

want to use/keep. 
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2. Use the Clip Raster by Mask tool. Specify the polygon layer as the Mask layer. Set the output 

resolution and data type to be the same as the input. If you want to import the raster to CAD 

then you can specify to create a world file using TFW = YES. Then click Run. 

3. See the before and after examples below. 

4. Now you won’t accidentally visualize or cut sections through meaningless edge-effect parts of 

the raster. 
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Original interpolated surface (in grey scale). 

 

 

Clipped interpolated surface (in grey scale). 
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3.4 Import CSV (or space/character delimited) data 

Any tab/space/comma/character separated data can be imported to QGIS. If there are easting/northing 

or latitude/longitude fields in the data then point geometry will be created, if not you can import the data 

as a table. 

1. Go Layer>Add Layer>Add Delimited Text Layer. 

2. Navigate to the file and set the appropriate data type (eg comma separated for CSV data).  

3. Specify the easting and northing fields (or columns). Specify the data CRS.  

4. You can adjust the data type of each column (eg text, integer or decimal number). 

5. Then click Add. 

6. If a point layer is added (as in this example) it is just a temporary on-the-fly layer specific to that 

QGIS project document. You will need to save to a shapefile (or another format) to keep as a 

spatial dataset that can be used elsewhere. 
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3.5 Create evenly spaced section lines/chainage locations along a stream 

centreline 

This follows the best answer method from here: 

https://gis.stackexchange.com/questions/380361/creating-perpendicular-lines-on-line-using-qgis 

 

1. Clean up your stream centreline a bit so it's less 'chunky' (add more vertices/detail around corners). 

2. Use the 'Points along geometry' tool to create evenly spaced points along your centreline. You can 

specify the spacing and an offset from the start/end. This tool adds an angle field to the output which 

contains the angle of the stream centreline at that location. 

3. Use the 'Geometry by expression' tool to create perpendicular lines at each point. Specify your new 

point layer. Paste in this expression to make 2km long section lines. This expression uses the "angle" 

field from the point layer to set the angle and you can adjust the '1000' value to set the length of the line 

either side of the point. 

extend( 

   make_line( 

      $geometry, 

       project ( 

          $geometry,  

          1000,  

          radians("angle"-90)) 

        ), 

   1000, 

   0 

) 

Use these lines as your section cuts for the Profile tool. And export these lines to DXF so you can bring 

them into AutoCAD. 

 

3.6 Create (section) lines anywhere along a stream centreline 

1. Create a new line layer. Draw a line parallel to your stream centreline (use snapping on the segment). 

https://gis.stackexchange.com/questions/380361/creating-perpendicular-lines-on-line-using-qgis
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2. Use the Rotate tool from the Advanced Digitising Toolbar. Using snapping to specify the exact point 

on the line at which you want to rotate, then type in 90 deg to rotate to the perpendicular. 

 

3. You might also like the Advanced Digitising toolset which gives you more CAD-like control over 

angles/distances of your lines. Toggle angle relative to last segment and lock distance/angle are good 

features to use if you want to extend the length of your section line, say. 
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3.7 Reordering attributes in attribute table (permanently) 

The Refactor fields tool can be used for reordering attributes in an attribute table (permanently, not just 

per project). It can also be used to add/remove attributes, change attribute value types (eg text to 

integer) or rename attributes – although these things can also be done via the layer Properties with 

editing toggled on. 

1. Activate the layer you want to adjust (highlight in the Layers panel). 

2. From the Processing toolbox search for the Refactor fields tool.  

3. Ensure the right layer is showing in the Input layer box. Then make the changes you want: 

a. Reorder attributes by selecting the attribute and using the up/down arrows to change 

the order (vertical order here translates to horizontal order in the attribute table). 

b. Add fields using the yellow star button. Remove fields using the red star button. 

c. Use the Source Expression settings to add value calculations to new fields. 

d. Adjust the field types under the Type setting and the field length under the Length 

setting. 

4. Specify a location to save the output refactored file, or just leave the default of creating a 

temporary output file.  
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3.8 Digitising polygon data (vegetation mapping) 

3.8.1 Layer preparation 

1. In QGIS, create a layer with the required cadastral lot (or area of interest polygons – the outer 

boundary of the area you’re mapping).  

Reproject this layer to a projected coordinate system (eg. GDA94 MGA50 or GDA2020 MGA50 

or GDA94 PCG94 etc). This is because it’s best to digitise with data in metres not degrees.  

 

Set the QGIS project coordinate system to a projected coordinate system. 

2. If the digitising (or other) tools are not working then it may be because there are issues with the 

original polygon geometry. Use the Check Validity tool (via the Processing Toolbox) to check if 

the polygon is invalid. If it is noted as invalid then zoom to the spots marked in the Error output 

point dataset and fix the errors in the geometry (eg. Self-intersection). You can use the Fix 

geometries tool to fix these validity errors (not other geometry errors). 

 

 

3.8.2 Tool setup 

3. Check the Advanced Digitising and Snapping toolbars are visible in the main toolbar area. If not, 

right click in that grey area and tick the toolbars on the list. 

The Advanced Digitising toolbar: 

 

The Snapping toolbar: 

 

4. Set the snapping settings as below: 
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• Turn snapping on by clicking on the ‘Enable snapping’ button. 

 

• Select to snap to the active layer only. 

 

• Select Vertex and Segment snapping options (but not the other options). 

 

• Select Enable Snapping on Intersection 

 

• The default tolerance of 12 px is fine. 

 

3.8.3 Creating polygons using Split Features, Fill Ring, Merge and Reshape tools 

5. Activate the area of interest layer (click on the layer name in layer list). Click on the ‘Toggle 

Editing’ button on the Digitising toolbar. This turns on editing mode. 

 

Save your edits between each of the following steps using the ‘Save Layer Edits’ button. 
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After all editing is finished untoggled the editing mode by clicking on the Toggle Editing button 

again.  

6. To cut a feature in two use the Split Features tool from the Advanced Digitising toolbar. 

 

7. Use this tool to cut the original area of interest into multiple features. Do this by drawing a line 

that crosses the outer boundary of a feature at at least two points (red line below). Do many 

clicks to define the cut line and right click to end the cut. 

 

The original feature is now split into two features: 

 

 

8. If you want to cut one feature only but your cut line will pass through another feature, then first 

select the feature you want to cut.  
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Select the feature to cut, then using the Split Features tool draw the cut line through all the 

features: 

                              

See that only the highlighted feature is split in two: 

     

 

9. To cut out a donut feature, use the Fill Ring tool from the Advanced Digitising toolbar. 

 

 

10. Use this tool to cut out a new shape in the middle of the original feature. Do many clicks to 

define the new feature boundary (in red below) and right click to end the cut. Do not cross or 

snap to any feature boundaries. 
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The original feature is now split into a filled donut. 

 

 

11. If you need to reshape any of these feature boundaries, use the Reshape Features tool from the 

Advanced Digitising toolbar. 

 

This tool will reshape both features either side of a shared boundary at the same time. To do 

this, make sure to snap to vertices (not segments). Both boundaries will only be reshaped if you 

snap to shared vertices. 
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Eg. Original geometry, the Reshape Tool line (in red), then the final feature geometry with 

altered boundary. 

 

 

  

12. If you want to use the Reshape Features tool but don’t have a vertex at the correct location then 

you can add vertices to boundary lines before using the tool.  

First select one feature of the shared boundary. Use the ‘Vertex Tool’ from the Digitising 

toolbar.  

 

 

Click on the line segment at the red plus symbol (the line will be dragged with the cursor) then 

click again on the line segment in the location where you need a vertex (using segment 

snapping). 

 



28 

 

 

 

 

Then repeat this process for the other feature on the shared boundary and snap to the vertex 

just created (use vertex snapping this time). There should now be two new vertices at the same 

location, one for each adjacent feature. 
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13. If you want to merge two features into one, use the Merge Features tool from the Advanced 

Digitising toolbar.  

 

 

First select the two features you want to merge, then click the Merge Features button. You will 

be asked which attribute values you want the merged feature to inherit. 
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3.8.4 Difference and Union tools 

These tools are useful for cutting up polygons based on polygons in other layers.  

1. Union is useful when you want to split one layer by another layer and include the attribute fields 

from both layers in the output. Eg. Split the pink polygons by the black ones. The input layers do 

not have to have the same extent (as in this example). 

 

2. Open the Union tool via the Processing Toolbox. 
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3. Specify the two layers you want to combine and the output dataset. 

 

4. The output contains all input layer polygons split along over layer boundaries and the attribute 

table contains all data from both input layers. 

 

5. The Difference tool is used to extract the spatial difference between two layers – one layer 

minus the other. Eg. the gap between purple and green layers. 

 

6. Open the Difference tool via the Processing Toolbox. 
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7. Specify the two input layers and the output dataset. 

 

8. The output will be the yellow layer and the attribute table will contain only the data of the 

original Input layer. 
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3.9 Cleaning data – overlaps, gaps and self-intersection errors 

This video has a good demonstration of a data cleaning workflow for QGIS and MapShaper: 

https://www.youtube.com/watch?v=iyDj8AvX3H0 

3.9.1 QGIS tools used to fix invalid geometry 

• Check validity 

Checks for self-intersecting polygons and duplicate vertices which cause invalid geometry 

(which prevents other processing tools from running). Accept all defaults when running the 

tool. This just identifies where these errors are, it doesn’t fix them. 

• Fix geometries 

This fixes self-intersection and duplicate vertex issues. Doesn’t fix gaps or overlaps. Run the 

Check validity tool again afterwards to confirm validity errors are fixed. 

3.9.2 QGIS and Mapshaper tools to fix topological errors 

• Topology checker 

This tool checks data against sets of rules to find topological errors (overlaps and gaps etc). 

This tool runs with very low tolerances so it will find the smallest of errors. 

1. Enable tool via Plugins>Manage and Install Plugins. Search for Topology checker and tick it 

on. 

2. Open the tool via the Vector>Topology checker menu. 

3. In the tool panel open Configure. 

 

 

4. Select the layer you want to check and specify the rules you want to use. Click OK. For 

example: 

 

https://www.youtube.com/watch?v=iyDj8AvX3H0
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5. Then run the check using Validate All. 

 

6. The output will list the topology errors and they will be highlighted red on the map canvas. 

This tool does not fix these errors, it just identifies them. You can fix them manually if there 

are only a few. 

 

 

• Mapshaper.org 

At mapshaper.org there are tools to fix topological geometry errors like overlaps and gaps. This 

tool just runs in the browser, no need to install anything. 

7. Go to mapshaper.org. Drag in your shapefile and accept the import defaults. 

8. Click on Console to open a command window. 

 

9. Type help clean and press enter to see all the topological cleaning options. Then type 

clean and press enter to run the clean command with default parameters. 
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10. This may have been sufficient to catch all overlap and gap errors. Export to shapefile suign 

the Export tab. Rename the layer when you export from Mapshaper. It will download to 

your Downloads folder. 

 

 

11. Open the exported dataset in QGIS. There appears to be a glitch with GDA2020 MGA50 

layers and Mapshaper can’t export the .prj file. Use the Assign projection tool to add the 

coordinate system information back to the layer. 
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12. Run the Topology checker again on this dataset to confirm if all issues are fixed. You need 

to remove all the previous rules and add new ones for the new layer. 

13. If not all the gaps have been removed you can use the command clean gap-fill-

area=<threshold> when running Mapshaper. Where <threshold> is the maximum area 

of the gaps you want to catch. 

 

4 Data conversions 

4.1 From QGIS to AutoCAD 

4.1.1 Elevation contours 

If the dataset has elevation values (eg. contour lines), then the shapefile needs to be converted to a 3D 

shapefile before being exported to dxf. 

These are the steps for conversion and export: 

1. Clip out the area of interest to make a smaller contour layer. Reproject if need be. 

2. Open the Processing Toolbox. 

3. Search for v.to.3d  ‘Set Z value’ and open the tool. 

4. Select the clipped contour shapefile, select the elevation attribute from the drop down menu 

under ‘Name of attribute column used for height’ the Data Defined Override button for Z Value, 

specify the name for the temporary or saved output file. If the elevation attribute doesn’t show 

it means it’s saved as a string not a number and you’ll need to convert it to a number before 

running the Set Z value tool. 
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5. Leave the other defaults and run the tool. 

6. After the output layer has been added to the map view, right click on it and ‘Save As’. Select 

AUTOCAD DXF as the format, specify the output coordinate reference system, specify the 

geography as LineString and check that ’Include z-dimension’ is ticked.  

7. The resultant dxf file will overly correctly with other layers of the same coordinate system in 

AutoCAD, and the elevation value will show in the layer properties in AutoCAD. 

4.1.2 Other vector layers 

For all other vector layers that don’t have elevation values it’s best to convert to dxf using the Export 

Project to DXF tool. This tool brings some symbology (styles and labels) with the layers and allows you 

to export multiple layers at once. 

1. Reproject all the layers you want to export to the coordinate system you’re using in the 

AutoCAD project. 

2. Clip layers if you want them to have the same clean boundaries (otherwise data to export is 

selected based on a selection of what’s showing in the map view). 

3. If you want polygon layers to export as polylines then convert the data to lines using the 

Polygons to lines tool. Polygon layers export as hatches. 

4. Set layer styles and labels (if you want those to export with the data). 

5. Zoom your map view to the extent you want to export. 

6. Go to Project>Import/Export> Export project to DXF. 
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7. Specify the output dxf file. Choose Symbology mode = Feature symbology (if you want to 

export styles and labels). Set the scale at which you’ll use the data. Set the output CRS (the 

coordinate system of your AutoCAD file). 

8. Tick on only the layers you want to export. You can only export layers that are in the target CRS. 

9. Tick on three of the options (unless you don’t want to export labels) as per the screen shot. 
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4.1.3 Images/rasters/surfaces 

1. In QGIS georeference the image using Raster > Georeferencer.  

2. Use right click Save As on the raster layer. Leave the resolution as is (or make it lower 

resolution if desired). In the Create Options use TFW = YES to create a world file. 

3. The resultant file should be a tif with a .tfw file. This can be imported into AutoCAD and will 

overlay correctly when positioned using the GEOREFIMG tool. 
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4.2 From QGIS to Illustrator 

If the scale of an existing or intended Illustrator file is known then it is quicker to export data from QGIS 

as a pdf (at the correct scale) rather than as a dxf layer that will need to be re-scaled in Illustrator. These 

are the steps for exporting data to 1:10 000 at A3, for example. 

1. Set the QGIS project coordinate reference system to the one you want to use for the Illustrator 

file, via Project>Project Properties>CRS. 

2. Open the A3 Landscape For Export to Illustrator print layout from the QGIS template project (or 

set up an blank page with a map/scale/legend items added and a transparent background). 

3. Zoom and pan to the project area.  Set the scale to 1:10000. 

4. In the map Layers window turn on only one layer. 

5. From the Print Layout window export the map to pdf – Layer>Export as PDF. If exporting vector 

data be sure to tick ‘Export as Vector’ so you get a vector PDF. 

Exporting to PDF preserves all the line and polygon geometry as it is in QGIS, so it’s easy to 

work with the data in Illustrator. 

6. Repeat 4 and 5 for all QGIS layers you need in Illustrator. This means the layers will all overlay 

correctly when opened in Illustrator with no resizing or scaling required – just use Paste in 

Place to combine layers. 

OR 

7. If you want want to export multiple (vector) layers at once and preserve text for editing then 

export to SVG. Replace Step 4 onwards with: 

8. Leave all vector layers you want on in the Layers window.  

9. In the Print Layout window go to Layer>Export as SVG. Tick ‘Export as SVG Groups, ‘Export as 

Vector’, ‘Simplify Geometries’ and ‘Export text as Text Objects’. 

The output SVG can be opened in Illustrator but some geometry may be broken (eg exploded 

into multiple segments). 

See here too: https://www.youtube.com/watch?v=6luermhPfFc&ab_channel=JessZimmerman 

 

4.3 From AutoCAD to QGIS 

The easiest way to bring a dwg or dxf into QGIS is using the Project>Import/Export>Import layers from 

DWG/DXF tool. This imports the data to a geopackage file (gpkg) and brings all the layers and colours 

from the AutoCAD file. Specify the CRS of the AutoCAD file. Tick the Expand block references option 

and Use curves options. Specify the Group name. Then click Import. After the layers show then click 

Okay. It will often take some time to import layers. 

https://www.youtube.com/watch?v=6luermhPfFc&ab_channel=JessZimmerman
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Another way to go from AutoCAD to QGIS is to use the MAPEXPORT tool from AutoCAD Civil 3D. This 

method is good if you want elevation values of contours to come with the data, say. This produces a 

shapefile that takes the coordinate reference system of the .dwg file from which it is was exported, and 

accessible attribute data. 

 

5 Data Sources 

5.1 SLIP downloads 

The Shared Land Information Platform (SLIP) data is now accessed via data.wa.gov.au. Registration is 

required to access the publicly (freely) available shapefiles. Steps are as follows: 

1. Register an account from the link on the data.wa.gov.au homepage. 

2. Search for data via the search box on data.wa.gov.au, or browse through the groups of 

datasets under the groups tab. 

3. Click on a dataset and check if it says ‘shapefile’ at the bottom of the page. Click ‘Go to 

Resource’. There will be a login prompt then the shapefile will start downloading. If it doesn’t 

download it means it’s a restricted dataset that can only be accessed with a paid subscription. 

 

5.2 SLIP WMS/WFS layers 

Many layers on SLIP are available as WMS and WFS layers. Layers like aerial photos are particularly 

useful if you have access to a UWA/other university SLIP subscription (they are not available to public 

accounts). 

5.2.1 WMS/WFS available with public access 

Latest satellite image mosaic 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Locate/MapServer/WMSServer 

Public SLIP layers as Web Mapping Service (WMS) (raster) and Web Feature Service (WFS) (vector) are 

listed here: https://catalogue.data.wa.gov.au/group/?q=SLIP+Public 

Click on the group of interest then go to the About tab to find the WMS/WFS URL 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Locate/MapServer/WMSServer
https://catalogue.data.wa.gov.au/group/?q=SLIP+Public
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5.2.2 WMS/WFS available with subscription access 

Satellite and aerial imagery by year - Perth 

https://catalogue.data.wa.gov.au/dataset/perth-metro 

https://catalogue.data.wa.gov.au/dataset/perth-metro-archive 

Satellite and aerial imagery by year - Regional 

https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic 

https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic-archive 

Other vector layers 

https://catalogue.data.wa.gov.au/group/?q=subscription&sort=title+asc 

 

5.2.3 Add WMS/WFS layers to QGIS Browser 

 

1. To add these layers in QGIS copy the URL from one of the above webpages. 

 

https://catalogue.data.wa.gov.au/dataset/perth-metro
https://catalogue.data.wa.gov.au/dataset/perth-metro-archive
https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic
https://catalogue.data.wa.gov.au/dataset/wa-regional-aerial-photography-mosaic-archive
https://catalogue.data.wa.gov.au/group/?q=subscription&sort=title+asc
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2. In QGIS go to the Browser panel then right click on WMS/WMTS > New Connection. 

3. Give the connection a name and paste the URL. Leave the Authentication setting as No 

Authentication.  

Tick on ‘Ignore axis orientation’ and ‘Ignore reported layer extents’. 

Click OK. 

 

4. For subscription layers, when you drag and drop WMS layer from Browser to Layers panel in 

QGIS a login box will open so you can fill in your SLIP login details.  

5.3 Nearmap 

You need a Nearmap account/subscription (eg. via a university). Login to the nearmap.com website, 

then: 

1. Click on the blue Map Browser button. 

2. Navigate to your site. 

3. Click on the Exports button (on the lefthand side menu bar). 

4. Select Georeferenced image from the Export type. 

5. Select the coordinate system of your AutoCAD project (most important to match to CAD data 

because AutoCAD cannot reproject images. QGIS can reproject on the fly). 
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6. Select the highest possible resolution and click Download Files. 

In QGIS 

7. Load the tif file into QGIS. You will notice that the coordinate system is ‘undefined’ and the 

image may not show in the correct location. You need to assign the correct coordinate system. 

8. In the Processing Toolbox search for the Assign projection tool.  

9. Add the Nearmap tif as the Input layer, then choose the Assigned CRS by clicking on the globe 

icon and searching for the EPSG number in the Nearmap image file name. This ensures you’re 

assigning the same coordinate system as you specified when downloading the data. Then run 

the tool. Now the image will know its coordinate system next time you open it. 

In AutoCAD 

10. After step 6, attach the image to your AutoCAD file and place anywhere when you add it.  

11. Use the GeoRefImg tool to move the image to the correct location 

12. This works provided you have downloaded the image in the same coordinate system as the 

AutoCAD project, and that you keep the .jgw file next to the jpg and with the same file name. 

 

5.4 Other base layers for QGIS 

XYZ layers 

There is a great plugin for QGIS called QuickMapServices – this allows you to easily search for and add 

XYZ tiled base layers to your QGIS project. Install this plugin. Then find it under the Web tab.  

Add the OSM standard render to get a street map or click on Search QMS to search for Google or ESRI 

base layers (and many many others).  

Or, you can choose to add XYZ tile layers using these URLs (it’s the equivalent to using 

QuickMapServices). 

OpenStreetMap: http://tile.openstreetmap.org/{z}/{x}/{y}.png 

Google Hybrid: https://mt1.google.com/vt/lyrs=y&x={x}&y={y}&z={z} 

Google Satellite: https://mt1.google.com/vt/lyrs=s&x={x}&y={y}&z={z} 

Bing satellite: https://t0.tiles.virtualearth.net/tiles/a{q}.jpeg?g=685&mkt=en-us&n=z 

 

https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-in-qgis 

 

http://tile.openstreetmap.org/%7bz%7d/%7bx%7d/%7by%7d.png
https://mt/
https://mt1.google.com/vt/lyrs=s&x=%7bx%7d&y=%7by%7d&z=%7bz%7d
https://t0.tiles.virtualearth.net/tiles/a%7bq%7d.jpeg?g=685&mkt=en-us&n=z
https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-in-qgis
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6 Data onto GPSes and tablets 

6.1 GPS 

When loading data onto GPSes for field work it is useful to load gpx and img versions of the data. 

One work flow to create the data: 

1. Export the desired data from QGIS to kml (specifying the Datasource Options> NameField as 

the field with the data labels). 

2. Open this kml (and kmls of any other layers) in BaseCamp (download the installer from here: 

https://www.garmin.com/en-AU/software/basecamp/) . Set the layer colours and pin styles. 

3. Go to File>Export ‘My Collection’ to save all loaded layers to a gpx file. 

4. To create an img file use the application IMGfromGPX (from here 

https://www.javawa.nl/imgfromgpx_en.html). Using the img file prevents you from having to 

load each track in the gpx to the map view manually. 

To load the data: 

1. Plug in the GPS 
2. Once the GPS loads open it in a Windows Explorer window.  
3. Drag the .img file into the Garmin folder (the first folder level). 
4. Drag the .gpx file into the GPX folder. 

 

6.2 Tablets 

There are many apps available for using spatial data/maps on tablets. We have been using Avenza 

because it’s quite simple to use.  

Steps to creating maps in QGIS for use in Avenza (https://www.avenzamaps.com/): 

1. Create a map as normal in a QGIS print layout. 

2. When exporting the map to pdf make sure the Append georeferenced information option is 

ticked.  This means the pdf will be georeferenced. 

 

3. Then copy this map to the tablet. In Avenza click on Import maps and navigate to the map. So 

long as the tablet has a GPS or simcard with data then you will get a blue dot on the map to 

show your location. 

4. You can also add kml layers to Avenza so that the data is clickable (the map layers are not). 

Avenza has limited zoom levels so to maximise how far you can zoom in to a map it’s recommended to 

export to A0 (rather than A3, say). Particularly with aerial photos where you want to see the detail. 

https://www.javawa.nl/imgfromgpx_en.html
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7 Importing ESRI style files to QGIS 

Converting ESRI .style files to QGIS .xml 

You need a licensed (paid) version of the SLYR plugin to convert .stylex (ArcGIS Pro) files to QGIS xml 

files. So you can only convert .style files. But… there are no .style files available through ESRI style 

catalogues anymore and you can’t convert .stylex files to .style files. 

So this work flow is not of much use, but here in case you have some styles in ArcMap that you want to 

export for use in QGIS. 

To convert ArcGIS .style files: 

1. In QGIS, install the SLYR plugin via the Plugin Manager. 

2. Then go to Settings>Options>SLYR and under the MDB Tools section click to download the 

MDB Tools files and save somewhere. Unzip and point to that folder location. 
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3. From the Processing Toolbox menu find the SLYR plugin and open the Convert ESRI style to 

QGIS style XML tool. Point to the ArcGIS .style file to be converted and specify the output 

location. 

 

 

Downloading .xml style files for QGIS 

There are some QGIS styles to download here: https://plugins.qgis.org/styles/?page=7&& 

 

https://plugins.qgis.org/styles/?page=7&&
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Importing .xml style files to QGIS 

4. In the QGIS Browser panel, navigate to where the .xml style file is saved (this could be one 

you’ve downloaded or converted). Right click on the .xml file and choose Import Style. Then 

select which styles to import (or select all), choose to add tags and choose to add the imported 

styles to your Favourites. 

 

 

 

5. To apply the imported styles, open the Properties>Symbology of the layer to be styled. Open the 

Style Manager. In there you can search for styles by tags and type. Right click on a style to add 

it to your Favourites. Then close the Style Manager and choose the style you want from the 

Favourites panel. 
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